Get the existing OS to date with both Kernel and packages.
- freebsd-update fetch install
- pkg update & pkg upgrade
Initial commands, to record what’s currently installed and tidy up caches etc
- portmaster –list-origins > ~/installed-port-list-`date “+%Y-%m-%d-%H%M%S”`.txt
- portsnap fetch update
- portmaster -ty –clean-distfiles
- portmaster –check-port-dbdir
- portmaster -Faf
Upgrade the OS
This bit takes a while, about 20 minutes.
freebsd-update upgrade -r 11.2-RELEASE
root@hostname(/home/user)# freebsd-update upgrade -r 11.2-RELEASE src component not installed, skipped Looking up update.FreeBSD.org mirrors... none found. Fetching metadata signature for 10.4-RELEASE from update.FreeBSD.org... done. Fetching metadata index... done. Fetching 1 metadata patches. done. Applying metadata patches... done. Inspecting system... done. The following components of FreeBSD seem to be installed: kernel/generic world/base world/lib32 The following components of FreeBSD do not seem to be installed: world/doc world/games Does this look reasonable (y/n)? y Fetching metadata signature for 11.2-RELEASE from update.FreeBSD.org... done. Fetching metadata index... done. Fetching 1 metadata patches. done. Applying metadata patches... done. Fetching 1 metadata files... done.
sds
You might be asked to confirm some merges. Do whats required. Once finished you’ll be told to run…
/usr/sbin/freebsd-update install
This runs pretty quickly..
/usr/sbin/freebsd-update install
src component not installed, skipped
Installing updates…
Kernel updates have been installed. Please reboot and run
“/usr/sbin/freebsd-update install” again to finish installing updates.
I got stuck in a reboot loop at this point. Recording my VM’s screen I spotted the following error…
module_register_init mod_load vesa error 19
I know I was loading the vesa module to get a better screen resolution on the console. To resolve the issue I booted off a FreeBSD bootonly ISO, mounted my root partition to /mnt and commented the line loading the vesa module out of /mnt/boot/loader.conf